Cannot change version of project facet Dynamic web


摘要 解决Cannot change version of project facet Dynamic web module to 3.0maven facet Dynamic web

 

目录[-]

问题描述

        用Eclipse创建Maven结构的web项目的时候选择了Artifact Id为maven-artchetype-webapp,由于这个catalog比较老,用的servlet还是2.3的,而一般现在都是用3.0,在Project Facets里面修改Dynamic web module为3.0的时候就会出现Cannot change version of project facet Dynamic web module to 3.0,如图:

其实在右边可以看到改到3.0需要的条件以及有冲突的facets,4

解决这个问题的步骤如下:

1.把Servlet改成3.0,打开项目的web.xml

 

?
12345<?xml version="1.0" encoding="UTF-8"?>


<web-app xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"


    xmlns="http://java.sun.com/xml/ns/javaee"


    xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/web-app_3_0.xsd"


    id="schedule-console" version="3.0">






2.修改项目的设置,在Navigator下打开项目.settings目录下的org.eclipse.jdt.core.prefs


把1.5改成1.7




?




1
2
3
4
5
6
7
8


eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.7
org.eclipse.jdt.core.compiler.compliance=1.7
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
org.eclipse.jdt.core.compiler.problem.forbiddenReference=warning
org.eclipse.jdt.core.compiler.source=1.7





3. 打开org.eclipse.wst.common.component 


本文件不用修改




?



1
2
3
4
5
6
7
8
9
10
11
12
13



<?xml version="1.0" encoding="UTF-8"?><project-modules id="moduleCoreId" project-version="1.5.0">


    <wb-module 
本站声明
本文转载自:http://331870401-qq-com.iteye.com/blog/2254140     作者:樊明涛     发布日期:2015-11-03     本站转载的文章为个人学习借鉴使用,本站对版权不负任何法律责任。如果侵犯了您的隐私权益,请联系我们删除。


 
© 2014-2016 ITdaan.com 粤ICP备14056181号